1. Help Center
  2. AgroScout Sky App

Supported Drones

We highly recommend using the Sky App with the DJI Mavic 2 Pro drone that is fully supported by AgroScout.

These DJI Phantom 4 models will also work with our app but are not officially supported (some functions might not work):

Phantom 4 Pro V1.0

Phantom 4 Advanced

Phantom 4 Pro V2.0 - only when using the DJI Smart controller.

All DJI drones models that have a "+" (plus) version which includes a built-in tablet with the controller, are not supported. Other DJI drones are not supported yet - we're working hard on adding more supported drones soon.